hdoj1241-DFS

题目描述

Problem Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either *', representing the absence of oil, or@’, representing an oil pocket.

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output

1
2
3
4
0
1
2
2

思路分析

使用DFS深搜即可解决,要注意的是,相邻点不仅仅包括直接相邻,还包括间接相邻。

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
#include <iostream>
#include <cstdio>
using namespace std;

// 遇到不合理的,则跳过,不用进行遍历
int m, n;
char grid[100][100];
bool mark[100][100];

// 实际上应该为8个相邻点,而不单纯指直接相邻
int go[][2] = {1,0,-1,0,0,1,0,-1,1,1,1,-1,-1,-1,-1,1};

void DFS(int x, int y){
mark[x][y] = true;
for(int i=0; i<8; i++){
int nx = x + go[i][0];
int ny = y + go[i][1];
if(mark[nx][ny] == true) continue;
if(grid[nx][ny] == '*') continue;
if(nx < 0 || nx >= m || ny < 0 || ny >= n) continue;
DFS(nx, ny);
}
}

int main(){
while(scanf("%d%d", &m, &n)){
if(m == 0 && n == 0) break;
for(int i=0; i<m; i++){
for(int j=0; j<n; j++){
cin >> grid[i][j];
mark[i][j] = false;
}
}
int cnt = 0;
for(int i=0; i<m; i++){
for(int j=0; j<n; j++){
if(mark[i][j] == true) continue;
if(grid[i][j] == '*') continue; //跳过,无油
DFS(i, j);
cnt++;
}
}
printf("%d\n", cnt);
}
}