hdoj2544-最短路径

题目描述-最短路

Problem Description

在每年的校赛里,所有进入决赛的同学都会获得一件很漂亮的t-shirt。但是每当我们的工作人员把上百件的衣服从商店运回到赛场的时候,却是非常累的!所以现在他们想要寻找最短的从商店到赛场的路线,你可以帮助他们吗?

Input

输入包括多组数据。每组数据第一行是两个整数N、M(N<=100,M<=10000),N表示成都的大街上有几个路口,标号为1的路口是商店所在地,标号为N的路口是赛场所在地,M则表示在成都有几条路。N=M=0表示输入结束。接下来M行,每行包括3个整数A,B,C(1<=A,B<=N,1<=C<=1000),表示在路口A与路口B之间有一条路,我们的工作人员需要C分钟的时间走过这条路。
输入保证至少存在1条商店到赛场的路线。

Output

对于每组输入,输出一行,表示工作人员从商店走到赛场的最短时间

Sample Input

1
2
3
4
5
6
7
2 1
1 2 3
3 3
1 2 5
2 3 5
3 1 2
0 0

Sample Output

1
2
3
2

思路分析

此题的结点数量为100,可以使用Floyed算法来解决,如下:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
#include <iostream>
#include <algorithm>
#define INF 10000 // we can use -1
using namespace std;
int dist[101][101];
int main(){
int n, m;
while(cin >> n >> m){
if(n == 0 && m == 0) break;
fill(dist[0],dist[0]+101*101, INF);
for(int i=1; i<=n; i++) dist[i][i] = 0;
int a,b,c;
while(m--){
cin >> a >> b >> c;;
dist[a][b] = c;
dist[b][a] = c;
}
for(int k=1; k<=n; k++){ //k,i,j
for(int i=1; i<=n; i++){
for(int j=1; j<=n; j++){
if(dist[i][k] == INF || dist[k][j] == INF) continue;
if(dist[i][j] == INF || dist[i][j]>dist[i][k]+dist[k][j])
dist[i][j] = dist[i][k] + dist[k][j];
}
}
}
cout << dist[1][n]<< endl;
}
}

当然,也可以用Dijkstra算法来写。Dijkstra算法适合单源最短路径,当结点数量比较大时得使用这种算法,只是写起来会相对比较麻烦。注意下面的newP这个点。

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
#include <cstdio>
#include <vector>
using namespace std;
struct E{
int next; //neighbor
int c; //weight
};
vector<E> edge[101]; //LinkedList
bool mark[101];
int dis[101];
int main(){
int n, m;
while(scanf("%d%d", &n, &m) != EOF){
if(n == 0 && m == 0) break;
for(int i=1; i<=n; i++) edge[i].clear();//initialize
while(m--){
int a, b, c;
scanf("%d%d%d", &a, &b, &c);
E temp;
temp.c = c;
temp.next = b;
edge[a].push_back(temp);
temp.next = a;
edge[b].push_back(temp);//non-directional
}
for(int i=1; i<=n; i++){
dis[i] = -1; // not access
mark[i] = false; // no belong to set K
}
dis[1] = 0;//length = 0, the most near point
mark[1] = true;
int newP = 1;
for(int i=1; i<n; i++){//to define the rest n-1 point
for(int j=0; j<edge[newP].size(); j++){ //遍历邻居
int t = edge[newP][j].next;
int c = edge[newP][j].c;
if(mark[t] == true) continue;
if(dis[t] == -1 || dis[t] > dis[newP] + c){
dis[t] = dis[newP] + c;//update dis
}
}
int min = 123123123;
for(int j=1; j<=n; j++){
if(mark[j] == true) continue;
if(dis[j] == -1) continue;
if(dis[j] < min){ //找距离最短的点
min = dis[j];
newP = j;
}
}
mark[newP] = true;
}
printf("%d\n", dis[n]);
}
}